Posted in Family Planning

HELPPP!

Hellooo ladies! My LMP was May 22nd, I was supposed to start June 26th according to my app. I didn’t bleed BUT I did have brownish discharge for 3 days on and off. I took a test from walgreen, a cheap one and it looked like I faint positive. I waited a week and took a FR test and it was negative. Then a few days after I took like 3 dollar tests and also negative. On Sunday July 6th, I took an blue dye equate test and I looked like a positive, then again I took a FR test and it’s negative. It is now July 11 and still no period. No sore breasts, no nausea, just late period and mild cramping from time to time. I went to the doctor today and did a blood and urine test and now I have to wait 3-5 days for results. Ofcourse the urine test came back negative. But before I get my blood test results has anyone experienced any of this before?! Please let me know! Oh and I’ve always have had a regular period!

  • PK
    Jul 12

    How many months postpartum are you? Is this your first few periods after having your baby? I’m pretty regular myself but for the first several menstrual cycles after having my son, I was very irregular and once I went almost 2 months without having a period.

  • Sandra
    Jul 12

    I don’t have any children. This is my first time missing my period for this long, It’s always been on time but I’ve been getting negative results, except for the blue dye test I had took.

  • Gardenmom
    Oct 13

    Are you pregnant? I know this is an older post but I am having a very similar experience.